player crashes and software disappears

Comments

28 comments

  • Avatar
    Jim Coyle
    Hi - just had an occurrence of the same issue. RV software seems to be missing after a reboot.

    The machine restarts but sits at the Windows login screen. Once logged in (via Teamviewer) the RV software doesn't start and doesn't appear to be installed.

    I reinstalled RV and all was normal so asked for a media player reboot from the RV user panel and on restart it had happened again. No RV software running although this time it did auto login.

    Something strange going on.

    I have set my machines NOT to auto reboot until I see a resolution to this.
    regards,
    Jim Coyle
  • Avatar
    agenebek agenebek
    That exactly describes my issue. I have also set them to not reboot for now. But this is not the solution. If we have e.g. a power faillure the system will not auto restart.
    This is a very strange issue.
  • Avatar
    Jim Coyle
    Seems RV is ignoring my electing to NOT reboot. Player rebooted Windows this morning at the scheduled time even though I had set it to OFF.  The RV software was missing again. Reinstalled and back to normal. 

    I am working remote and having to use Teamviewer to correct this issue. If I shutdown Teamviewer it leaves a notification on screen. Thus I have to keep Teamviewer running all the time - and it still shows a Teamviewer logo in the bottom right of the screen. Normally I could shutdown Teamviewer and reboot but not now as it appears the RV software is being erased somehow after a reboot.

    This hardware has Windows 10 Pro 64Bit installed.

    regards, Jim Coyle
  • Avatar
    agenebek agenebek
    Same here. RV also ignoring NOT to reboot.
  • Avatar
    Darius Aleksas
    Try Crome Remote Desktop https://chrome.google.com/webstore/detail/chrome-remote-desktop/gbchcmhmhahfdphkhkmpfmihenigjmpp?hl=... This is what I use.

    Or buy full software license for TeamViewer
  • Avatar
    XMedia DDS
    We are also facing this issue since last 2 days. It just shows desktop. Now remotely logging into all the screens and starting the rv software.

    regards
    Prakash
  • Avatar
    Robb Price
    Thanks for letting us know everybody!

    Our Dev team will be investigating this today and, I will issue an update in this same forum conversation.

    Thanks!
  • Avatar
    Andi Northrop
    This may be unrelated but we experienced something similar the last couple of days where Rise Player was failing to start on one of our displays after a reboot. For us however the player was still present and would start if manually launched (though it sometimes took a couple of goes).

    We seem to have it stable again following an uninstall, reboot, reinstall.
  • Avatar
    Darius Aleksas
    I am gonna throw in my couple of cents. We had something similar few months ago. I took our perfectly functioning player to a different location for connectivity/functionality testing. To my surprise, after I came back, the RV App was missing completely from the machine. Go figure.
  • Avatar
    Robb Price
    For anyone experiencing this issue, can I ask you to email support@risevision.com with the affected Display ID's? That will help us determine similarities to track this down faster.

    Thanks!
  • Avatar
    agenebek agenebek
    Currently on a holiday. But will have access tonight. I will send you the id's of the 2 affected dusplays.
  • Avatar
    Jeffrey Barnes
    Looks in the logs like it's looking for a missing "...\Roaming\bookpc\serial-number" file or directory.
  • Avatar
    Alan Clayton
    Hi Jeffrey, that is just a warning and shouldn't cause Player to be removed. 

    Curious, could we get our remote access tool, Screen Connect, installed on that machine so we can take a look? We've not had any luck reproducing the issue on our side. Having access to a Display with the problem would really help. 

    If so, could you shoot us an email to support@risevision.com and we'll reply with the instructions to install ScreenConnect. 
  • Avatar
    Robb Price
    Hi there everybody!

    We have released a new Player version: RisePlayerElectron 2017.10.16.19.40, which includes a fix for the issue where Player doesn't autostart. That will be rolling out to all Displays over the next few days. 

    We are still investigating the scenario where Rise Player is removed and will provide updates as we learn more.

    Thanks!
  • Avatar
    Darius Aleksas
    Robb, what is really scary that you are releasing these quick, but important updates and forcibly pushing them on all player without proper testing. Would you consider, similarly to how Radeon handles these issues, not forcing the latest player updates and rather leave them optional? For example, it could be scheduled for a player to download by selecting this option in the Display Control panel, same as we have the button for Pro version.
  • Avatar
    Alan Clayton
    Hi Darius, as always, thank you for the feedback! 

    There are a couple reasons we don’t support that scenario, but the most important is complexity.

    Lets say over the course of a year your digital signage network had grown to 100 Displays. And because you are cautious, you decided to opt out of those Displays receiving updates. You now have 100 Displays running two versions of Rise Player -  version 1 and 2.  They are all running great until you add Widget X to your content. The Displays running version 1 show Widget X as expected, but the Displays running version 2 do not. 

    Should you downgrade the Displays running version 2 to version 1? Or should you investigate why Widget X isn’t working with version 2? There is no right answer, but they are both complex situations for a user.

    No matter what path you take, you’re likely to have increased the risk for something breaking in the future. If you went with the option to downgrade Player version, all 100 Displays on now running an old Player version resulting in an increased risk with something breaking in the future. And if you went with option 2, you have increased the code base for Widget X and now must support Widget X on both Rise Player version 1 and version 2. 

    Now multiply this situation by the 10, 100, 1000. Overtime, the increased complexity will break the camels back! For that reason, our approach is to keep moving forward. Learn from the mistakes and improve. 

    Having said that, I do think we can look at this from a different angle. Instead of providing the option to get left behind, thus increased risk for something breaking in the future, how do we mitigate the risk of introducing issues? 

    We’ve invested like crazy with automated testing and will continue to do so, but we have also discussed internally the idea of having a Rise Player Beta and Rise Player Stable.  The idea would be that you, or any other user, could setup a Display running Rise Player Beta to review changes to Rise Player before they are released to the stable version. Once a change has been released to 100% of the Beta Displays, we would then release the same change to the Displays running Rise Player Stable. 

    We’ve only had discussions so nothing planned at this point, but thought this might be a good opportunity to get feedback from you and the Community. 

    Let me know what you think. And if anybody else has thoughts or opinions, please don’t hesitate to let us know.

    Thanks!
  • Avatar
    Darius Aleksas
    Thanks Alan for taking your time to explain all that. Basically I was thinking Stable and Beta scenario, as you explained. It make me really nervous when all is fine on my end, but suddenly somebody else gets problems with their signage, and then you rush and fix their problem, but things get messed up on my end. And that evidently happened before. The Rise Vision is so awesome that one can play digital signage over the land line on a toaster, but for the same reason we can have so many things or combinations of them that can go south too. So I was just thinking maybe there should be a safer way to rush with updates.
  • Avatar
    Alan Clayton
    No problem Darius and thank you for the feedback. Your points are absolutely valid. And who knows, maybe someday we have to do something between the Beta/Stable idea and allowing a user to pick when to upgrade. We'll keep working to make this thing better and see where it takes us. These are good conversations! 
  • Avatar
    Jim Coyle
    Hi Robb,  Alan and the rest of the team.

    Much obliged for looking into this issue so promptly - it is greatly appreciated.

    Regarding the Beta/Stable release versions I am in favour. sounds like a sensible route and leaves the options open to the individual as to the risk level.

    regards,
    Jim Coyle
  • Avatar
    Alan Clayton
    We've been unable to replicate Player being uninstalled. We would like to get remote access to your machine so we can investigate further.

    If you can send us an email at support@risevision.com, we'll respond with the instructions on how to install ScreenConnect so we can see what is going on. 

    Thanks!
  • Avatar
    Sanna Fernqvist
    Hi there.
     Just wanted to tell you that we have still issues with the software "uninstalls" after reboot. although not every reboot, maybe after the second or third reboot.
    currently its only on one of the computers, using the 2017.10.16.19.40 version.

    Regards,
    Alex
  • Avatar
    Alan Clayton
    Hi Alex, just wanted to follow up with you. Are you still having this problem? If so, would it be possible to get ScreenConnect installed so we can remotely access? 

    Thanks
  • Avatar
    XMedia DDS
    Hi Alan,

    We are still facing the issue on couple of screens

    regards
    Prakash
  • Avatar
    Alan Clayton
    Thanks Prakash. 

    Can you email us at support@risevision.com and we will provide you with instructions to install ScreenConnect so we can take a look and see what is happening on your media players.
  • Avatar
    Sanna Fernqvist
    Hi!
    Sorry for not replying until now, we've had some issues with the PC/OS itself so there is a possibility that it is windows that screwing things up, and not risevision.

    I am currently troubleshooting it nad may end up reinstalling OS. And maybe rise works after that.

    I can get back to you afterwards.

    Regards
    Alex
  • Avatar
    Alan Clayton
    Would you like for us to take a look before you go through all that effort of reinstalling OS? 
  • Avatar
    Sanna Fernqvist
    Hi, not needed, i was in the middle of reinstalling when i saw your latest comment.

    regards
    Alex
  • Avatar
    Alan Clayton
    Okay, thanks Alex. Please let us know if you continue to see this problem. 

Please sign in to leave a comment.