Web Page Widget Refresh Not Working

Comments

17 comments

  • Avatar
    HSuarez
    Ritch,

    Which presentation/s will this be under? Is it also in the ARH account?

    Thanks,
    Hannah
    0
    Comment actions Permalink
  • Avatar
    Ritch Dunks
    The IDF Closet Check presentation in he ARH IT&S sub-company is one you can look at.
    0
    Comment actions Permalink
  • Avatar
    HSuarez
    Hi Ritch,
    Thanks for the additional info. If they are internal pages it looks like we won't be able to access it from outside but I will still need more details from you:

    1. Preview the presentation on your Chrome browser
    2. On the top menu go to View > Developer > Developer Tools
    3. Go to the Console tab
    4. There should be some error messages on Console. If not, refresh the page to reload.
    5. Take a screenshot of what you seen and attach here or send to support@risevision.com

    If you need any assistance or questions about this, let me know!

    Thanks,

    Hannah
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    I must to bring this one up again. For the few last weeks I have been struggling with the web page refresh simply not working for me... well, not entirely. I have two Web Page Widgets set in rotation. I am getting this problem with one of the pages. The widget is set to refresh every minute (this is how long the widget is visible before the next one comes up). I also marked to 'unload the page when not visible.' However, I believe, it only refresh the content of this page only at nightly hard player reset.

    I have no access to the page code. They (the page owners) usually update their content at night and the next morning it is all good on my end. However, if they updated their content in the morning, I get to see yesterday's info before my players reset again. It is happening on both Windows 10 and Chrome players. I have the access to both players and can reset them manually, but this must work without me getting involved.

    However, it seems that the widget has no issues updating Google Slides what so ever.

    Update:
    app restart did not work on Windows device; hard reset worked, although this is not an option... should not be

    hard reset did not work on Chromebox
    0
    Comment actions Permalink
  • Avatar
    Robb Price
    Darius,

    Just to confirm, you have the Web Page Widget set to refresh every X minutes, and it is NOT doing that on this one specific page, is that accurate?

    Any chance you could share the website with us? If you don't want to share it here, you can send it to support@risevision.com. Thanks!
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    Robb, that is correct. The webpage, http://researchparkdeli.com/Research_Park_Deli/Specials.html, is set to refresh every 1min using the Web Page Widget, but it did not do it on Friday until I manually restarted the Windows machine and even that did not do the trick for Chromebox. Preview: http://preview.risevision.com/?type=presentation&id=34c46163-0d33-4776-b846-689a17a42389

    Today it is working fine. Perhaps they updated their content yesterday.
    0
    Comment actions Permalink
  • Avatar
    Robb Price
    Thanks Darius!

    I will throw this into a Display over here and see if it updates over the next couple of days. Thanks!
    0
    Comment actions Permalink
  • Avatar
    Robb Price
    Darius,

    Interesting conundrum this morning...2 of my Displays that had rebooted overnight were updated, but as of 8:30 am, the other 2 that had NOT rebooted were still showing Specials for Tuesday. All are using that web page in the Web Page Widget, and refreshing every minute.

    When I looked over just after 9 am, ALL are now showing the specials for Wednesday! So sometime between 8:30 and 9 am, these updated as expected.

    Are you seeing the same thing?

    Thanks!
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    Two of my players that are restarting every night were showing today's menu when I got to work at ~8:30. And they usually are. But something goes wrong, in my case once in 2 weeks and it happened to be Friday both times, that brakes content refresh. As I mentioned before, one is Windows PC and the other is Chromebox. Let's ignore the Chromebox; although, in my situation it is the most important one. But the Windows player also stops updating until I do the hard restart. What bothers me that even simple player app restart does not help, and I am not even talking about 'publish' function. Also, all that happens to both players the same day. I do not know what to think.
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    I am not sure if it may have something to do with the page itself. Although, it looks really simple... silly even, but the code there is quite sophisticated, with JS and stuff. I believe it was made using some Apple software.
    0
    Comment actions Permalink
  • Avatar
    Robb Price
    I'll let you know if mine update tomorrow as well, so far, it's working as expected I would think, but I don't know how often this is supposed to update :)
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    Robb, one (Win10) of two players pulling the same presentation is not updating the web page again today.
    0
    Comment actions Permalink
  • Avatar
    Robb Price
    Darius,

    Unfortunately I'm not still testing this anymore. Are you saying that it was only one Display that is delayed, and the other is?
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    Robb, yup. Funny that Chromebox was working fine, but Windows 10 device did not update that Widget for the entire day. I deliberately left it like that just see if it would update at some point. Refresh is set to 1 min.
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    I though I was complaining about this before. I am gonna bring this one up again. The Web page Widget is still not updating. I have set it to update every minute. Although some things such as images and HTML structure did update, CSS styles did not. Forced reboot forced all the updates for the web page. This is till happening just as months ago on Windows 10 players, Pro version App installed just last week, Ethernet connection.
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    Today it is updating just fine. Not sure if I jumped the gun or you did change something.
    0
    Comment actions Permalink
  • Avatar
    Blake Freeman
    Hey Darius,

    Nothing was changed on our end regarding the Web Page Widget.
    0
    Comment actions Permalink

Please sign in to leave a comment.