Comments

7 comments

  • Avatar
    Robb Price
    Josh,

    Have you tested using the YouTube Widget?
    0
    Comment actions Permalink
  • Avatar
    Darius Aleksas
    One more! Josh, use html widget with this code:

    <!doctype html>
    <html>
    <head>
    <meta charset="utf-8">
    <title>Untitled Document</title>
    <style type="text/css">
    body {
    margin-left: 0px;
    margin-top: 0px;
    margin-right: 0px;
    margin-bottom: 0px;
    }
    #container {
    height: 720px;
    width: 1280px;
    overflow: hidden;
    position: absolute;
    }
    </style>
    </head>

    <body>
    <div id="container"><iframe width="1280" height="720" src="https://www.youtube.com/embed/playlist?list=YOUR-PLAYLIST-OR-VIDEO-ID-HERE&autoplay=1&loop=1&controls=0&showinfo=0" frameborder="0" allowfullscreen></iframe></div>
    </body>
    </html>

    adjust attributes as needed. Do some research before posting; we have discussed this before many times.
    0
    Comment actions Permalink
  • Avatar
    Josh McTighe
    Unfortunately as a school we do not have credit cards to make these transactions. When i tested rise a couple of years ago it worked fine in your old video player but it seems to have lost that functionality. 
    0
    Comment actions Permalink
  • Avatar
    Jody Watson

    Hi there all;

     

    @Darius Aleksas I looked at your code and tried to use it, no luck, had to click on it to start.  Here is the embed code that I have put in (Used NASA Live feed as a test).

     

    <!DOCTYPE html>
    <html>
    <head lang="en">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta charset="UTF-8">
    <title></title>
    </head>
    <body>
    <iframe width="1920" height="1080" src="https://www.youtube.com/embed/4993sBLAzGA?controls=0" frameborder="0" allow="accelerometer; autoplay=1; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
    </body>
    </html>

    Video will come up but I have to click on the video to begin playing it.  

     

    Here is the link to the page.  http://preview.risevision.com/?type=presentation&id=79cbe7f9-24e9-4eb5-8f0d-e839a5019349

     

     

    0
    Comment actions Permalink
  • Avatar
    Patrick Arsenault

    Hi Jody,

    It looks like all you're missing is the autoplay parameter in the embedded player URL.

     

    <!DOCTYPE html>
    <html>
    <head lang="en">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta charset="UTF-8">
    <title></title>
    </head>
    <body>
    <iframe width="1920" height="1080" src="https://www.youtube.com/embed/4993sBLAzGA?controls=0&autoplay=1" frameborder="0" allow="accelerometer; autoplay=1; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
    </body>
    </html>

    It won't work in Preview unless the video is also muted, but it should work on a Display.

    0
    Comment actions Permalink
  • Avatar
    Jody Watson

    That did the trick.  I think the preview threw me for a loop since when I would try it with that code it still would not open.

     

    Just for interests sake how do I mute the video?

     

     

    Thanks so much!

    0
    Comment actions Permalink
  • Avatar
    Patrick Arsenault

    Hi Jody,

    Glad that worked!

    To mute an embedded Youtube video, you should be able to set the mute parameter to 1 (https://www.youtube.com/embed/4993sBLAzGA?controls=0&autoplay=1&mute=1), but I've had mixed results doing this with live streams.

    The YouTube Widget and our Video Widget both have built in mute options in their settings, so you will likely get more consistent results using one of those (assuming the video is not a live stream).

    Unmuted videos should play normally on Rise Player; it doesn't work reliably in the preview because of a Chrome Update that disabled autoplay for unmuted videos.  You can find out more in this announcement from Google.

    Cheers,

    Patrick

    0
    Comment actions Permalink

Please sign in to leave a comment.