Google calendar issue

Completed

Comments

27 comments

  • Avatar
    Robb Price

    Sorry to hear that Benjamin!

    I've reached out to you in a private support ticket so we can investigate what the issue may be here.

    Thanks!

  • Avatar
    Susan Perry

    Hi Benjamin,

    This has been happening to us too!  Our cals go down probably every three days or so, but without (seemingly) rhyme or reason. I figured it was because we are running RISE on (un-officially supported) Chromebits, but maybe that isn't the issue... ??

    Can you tell me what hardware you're using? 

    I have talked to both Google and Rise support, and while both were very helpful, neither could offer any solutions as to the cause. 

    It's interesting to know other people are having this issue as well! 

    Thanks, Susan

     

  • Avatar
    Benjamin Jones

    Susan,

    We're using both the Amazon firestick with the 3rd party Rise app and also Windows sticks with the official Rise Vision app.

     

    I'm almost wondering if it's an API thing.

  • Avatar
    Robb Price

    Hi Benjamin!

    I responded via our support ticket about one thing I saw in regards to your Calendar setup, and I am currently running this Presentation on 2 of my Windows and Linux boxes over here to see how things fare over the weekend. 

    I'll be sure to let both you and Susan know!

  • Avatar
    Susan Perry

    Hi Robb and Benjamin,

    So interesting to know that perhaps this issue isn't just my chromebit, but an issue on a supported device as well!  Hopefully my situation may add another data point to this to get everyone a solution! :) 

    Quick background info: I opened a ticket on Feb 14th, Ticket 20612 (looked at by Kaden and Nick), and Kaden ran an overnight look at my bit, but saw nothing of note in the logs, even though the calendar widget did indeed go down during that time. His theory was an unsupported device, but with this new development today, I think Benjamin that you are on to something with the Google API. I know v3 of the Cal API came out in early December, and another cal API was shut down on 11/15/17 (https://gsuiteupdates.googleblog.com/2017/09/reminder-google-data-calendar-resource.html) and that's right around when our issues here started.  I was also reading about the possibility of it being https site content (the cal widget) loaded into an http-addressed page - essentially not playing nice for security reasons - but as it's inconsistent failures for both of us, I am guessing that's unlikely as the cause??

    Robb, hopefully you can use my ticket info to cross reference with Benjamin to see if any of my info helps! 

    Have a great weekend, my fingers will be crossed for all of us!

  • Avatar
    Robb Price

    Hi there everyone!

    Susan, I actually think that the Player may be the cause here, as hopefully Benjamin won't mind me mentioning that he is not running on a supported Player as well.

    My Windows and Linux Players ran great over the weekend, and are still running like gangbusters now. Were you ever able to test on a supported Windows or Linux device to see if the same thing happens?

  • Avatar
    Susan Perry

    Hi Robb and Benjamin,

    Thanks for the update. Unfortunately, I don't have access to a Win / Linux player, which is why I was so excited that someone else was having the same issue with a *supported* player. :) I know Benjamin's firestick isn't supported, but it sounds like he was having the same issue with his Windows player. Just out of curiosity, when you ran your simulations this weekend, is it within the app as if it is another device playing the scheduled presentation, or is it in something like preview mode in Chrome? Interestingly, I left my Chrome window up running one of my presentations in "preview", and it updated and was still pulling content fine as of this morning when I got in, but my Chromebit, however, running the *same* presentation, stopped refreshing and had the error we described above. It was really strange. 

    Benjamin, did both your players stay up this weekend? Have you been getting the errors on your different devices (Linux / Win) at the same time? 

  • Avatar
    Benjamin Jones

    Hey guys.. sorry for the late response.  My players are pretty much back to not displaying the dates.  They did stay up for a few days though.  I'm running both Amazon and Windows sticks.  I'll check on them later on.  Busy day today.

  • Avatar
    Robb Price

    No worries Benjamin,

    I've reached out to the Developer of the My Rise Player and brought this conversation to his attention to see if he can shed some light on what it may be.

    He'll be in touch soon!

  • Avatar
    William ONeal

    I haven't had many issues on our side but could it be with something with the wifi. The reason i ask is that all the sticks (windows and fire stick) seem to be on wifi. Robb i would test a device on wifi and have it lose connection and run on cache. I wonder how long it would take before it displays that message. Then if you get the message will it come back once the connection is established. Also lastly are the devices rebooting any at night. I have seen where devices boot up before the wifi gets connected and cause issue. 

    Lastly I also wonder if there is a timed reload in the spreadsheet once the widget gets the error. I Hope there would be but this could be something to look into as it would solve this issue if it just randomly happens. 

     

    I will keep testing. 

    Thanks

    Scott

  • Avatar
    Robb Price

    Thanks Scott!

    I'll do that and let everyone know what happens to me over here to see if I can recreate. Thanks!

  • Avatar
    Robb Price

    Hey everyone,

    Had a bit of a hiccup in my testing where the wifi came back on after a reboot, but I have disabled it at the hardware level today, and I am running this test over the weekend.

    I'll let everyone know on Monday how things look!

  • Avatar
    Susan Perry

    Hi everyone,

    Scott's theory about wifi is an interesting one, although it seems as if Benjamin's and my presentations themselves stay "up," it's just the widget that is losing connectivity? I am managing my bits through Google Admin, and I get an email if the device itself goes offline. They appear to stay "green" and are still connected, displaying Rise-hosted content just fine, even when the google widgets fail. Is there anything that I could run locally on the bit to log connectivity while in kiosk-mode to still display the content? I am open to suggestions if it's possible! 

    I know with the Google Sheets widget we could set an API to refresh content every X minutes, but I saw no such setting with the Calendar Widget? 

    For what it's worth, I have set half of my bits to reboot every night at 2am, and the other half not to, and have seen no difference between widget content loss - they all seem to fail at the same time, whether they are scheduled to reboot or not. 

    Hope this info is useful to you guys! 

     

     

  • Avatar
    Robb Price

    Susan,

    Everything has been running good for me so far, so I have restarted the test as of today, to see if anything weird occurs between today and tomorrow. 

    The steps are:

    1. Get the presentation running

    2. Confirm the calendar shows up (a calendar which has shown this "calendar is not public" message).

    3. Disconnect the Wifi to this Display.

     

    So far all is running well again, I will report back tomorrow if I see that message!

  • Avatar
    Robb Price

    Hey everybody,

    Try as I might, I cannot get this issue to happen on Windows or Linux. 

    Susan, I don't have any Google Chromebits to test on unfortunately, but just out of curiosity, do you have a Windows or Linux machine around that you could test the Presentation on to see if you can get it to occur there? If not, it must be OS related, but what the issue could be, I'm not sure of. At least we can pick off possibilities one by one!

    Thanks!

  • Avatar
    Susan Perry

    Hi everyone,

    Robb, unfortunately I don't have access to either Windows or Linux-running devices. We're a Mac school, and Chromebits was the least daunting departure from the Mac OS. :) 

    Benjamin, can you confirm that you are having the same error happen on both "flavors" of device (Windows and Firestick) at the same time? Or does only one type present with the error while the other batch is fine? 

    Thanks,

    Susan

     

     

  • Avatar
    Darius Aleksas

    Helps or confuses even more... but I have never seen that on any of my Windows devices (Sticks, Nucs, custom desktops and anything in between) or Chromeboxes (managed and non-managed). Never used Firesticks or Chromebits.

  • Avatar
    Susan Perry

    Hi Darius,

    Any chance you're using the Google Calendar widget in a presentation on your Chromeboxes? Are your Chromeboxes running the "unsupported" Chrome OS version of Rise, or do you have Ubuntu installed on top and a supported Rise player? 

    Thanks for your input! More data points are always good. :)

    -Susan 

     

  • Avatar
    Darius Aleksas

    Susan, I have Calendar Widget running in a presentation and running unsupported RV player app from Chrome Store on the unmanaged Chromebox. No other nonsense here. The Calendar Widget has custom layout... nothing major... just separator lines removed between items. And that is it.

  • I am having the same issue on one of my players. (Intel Compute Stick running Windows 10) 

     

    I get the same message every morning when I come in. Rebooting the computer usually clears it up. 

  • Avatar
    Kaden Christensen

    Hi everyone!

    Just wanted to provide a quick update here. We are still investigating the issue with Google Calendars. We'll be sure to update you here once we have more information.

    Thanks!

  • Avatar
    Darius Aleksas

    Happened to me for the first time today on Win 10 Regular player. WiFi network. 

  • Avatar
    Susan Perry

    Hi Kaden,

    Just wondering if there are any updates on a possible fix for our collective media players? 

    Thanks!

    -Susan 

     

     

  • Avatar
    Kaden Christensen

    Hello all!

    Just wanted to let you know that we're working on adding more logging to the calendar widget. It's going to take some additional time to collect and review the logs so that we can determine the source of the issue and provide a fix for it. We're hoping to gather enough information to know what the issue is by next week. We'll be sure to keep you updated with our progress!

    Thanks!

  • Avatar
    Shea Darlison

    Hi all, 

    I've posted an update in this announcement, we're trying to get both issues resolved as quickly as possible.  

    Thanks,
    Shea

  • Avatar
    Shea Darlison

    Hi all, 

    We believe both of the issues described in this announcement have been resolved but we're going to continue to closely monitor till the end of the week. If you see any issues with your calendars can you please open a support ticket by emailing support@risevision.com

    Let me know if you have any questions. 

    Thanks,

    Shea

Please sign in to leave a comment.