RSS Widget - Paragraph Spacing

Comments

2 comments

  • Official comment
    Avatar
    Patrick Arsenault

    For anyone else who experiences this, it turned out to be intended behavior in the RSS widget.  The stylesheet that is applied to the RSS widget resets the paragraph spacing and margins.

    In order to apply a custom RSS widget layout and add spacing like in the original post's example above, you will need to add the styling back to those paragraph tags.

    Option 1: Just add an in-line style in your custom layout that adds the margins to the paragraphs.  Since in-line CSS is considered most specific, this should be the easiest way to fix this.

    <p style="margin:10px 0;"></p>

    Option 2: Include a stylesheet in your custom layout html that adds the margins to paragraphs of a specific class.  You'll need to use a class to achieve this; I suspect the widget's CSS will be considered most specific if you just use "p".

    <style>
    p.some_class {
       margin:10px 0;
    }
    <p class="some_class"></p>

    Option 3: Download our repo from github and follow the instructions in the readme to run the build, host it and use it as a custom widget.  The style is set right here.

    Hope that helps!

    Cheers,

    Patrick

  • Avatar
    Patrick Arsenault

    Hi Trevor,

    It sounds like Wordpress and Feedburner handle paragraph (<p>) tags differently than Rise Vision.  I'd love to take a closer look, so I've gone ahead and opened a ticket for you.  You should receive an email with the details.

    Cheers,

    Patrick

Please sign in to leave a comment.